We can now connect to FTP on the P1 and A1 Series

Looks like FTP works on the P1 and A1 series now! It does not require LAN mode to use, either :slight_smile:

More specifically FTPS (port 990 / implicit FTP over TLS). Note that FTPS is not the same as SFTP!

The username is bblp.
The password is the access code found on the printer LCD within the WiFi settings.

FileZilla quickconnect example:
(note the ftps:// before the IP address)

FileZilla site manager example:
(note the Require implicit FTP over TLS encryption setting)

Once connected, it looks something like this:

Speeds are slow due to the ESP hardware used in the printer, so I recommend only transferring a single file at a time.



Ok I successfully connected to my P1P printer in lan mode. I created a folder on the Card and uploaded from the MicroSD card to my computer using FileZilla
But I cannot upload to the card

Status: Connecting to…
Status: Connection established, initializing TLS…
Status: TLS connection established, waiting for welcome message…
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing…
Status: Directory listing of / successful
Status: Starting upload of C:\Users\denwa\Desktop\bbl.gcode
Command: TYPE A
Response: 200
Command: PASV
Response: 227 (192,168,1,102,7,232)
Command: STOR bbl.gcode
Response: 150
Error: Transfer connection interrupted: ECONNABORTED - Connection aborted

Help would be appreciated


1 Like

I just tested creating a directory and uploading to it and it seemed to work without issue. I also uploaded to the root, however I did get one connection interruption like yours. I cancelled and tried again without issue.

I can download from the card, create folders on the cad and I can upload small text files.
but I cannot upload larger code files.

Any help would be appreciated


1 Like

I can initiate the connection but I get an almost immediate error when file Zillow tries to list the ftp server contents.

1 Like

Server returns a 530 when sending password. Yes, I confirmed it was correct. I also regenerated the code and tried again.

edit: The username is bblp not bblb as in the OP.
edit2: Seems the P1P FTP server crashes immediately when sending a file.


I consistently just get an error after an initially successful connection:

|Status:|Logged in|
|Status:|Retrieving directory listing...|
|Response:|257 /|
|Command:|TYPE I|
|Response:|200 |
|Response:|227 (0,0,0,0,7,232)|
|Error:|The data connection could not be established: WSAEADDRNOTAVAIL - Cannot assign requested address|
|Response:|150 |
|Error:|Connection closed by server|
|Error:|Failed to retrieve directory listing|

Tried a different FTP app to FileZilla and initially getting the same error but found this setting fixed it:

Today I’m having the same issues as others.

Which FTP program is your screenshot from? I can’t find that setting in FileZilla

On the top menu do a Wizard setup then you get the option as per below


That does not work for me

1 Like

Forcing Passive mode can be done on the connection profile but it doesn’t seem to help. The issue seems to be with filesize. Small files work okay but larger ones don’t want to transfer

I agree I can upload small text files, create and delete directory’s. Anything but gcode. Yeah BBL we can connect but we cant do anything else.

I logged a bug that trying to upload files > than ~256kb resets the printer. Which really sucks if it’s mid-print. Luckily I was only printing a blocky benchy to see how well the hard overhangs worked in practice.

1 Like

The working FTP program for me is WinSCP.

That doesn’t work for me. Still get the same error from FileZilla:

Yes WinSCP does not work same disconnect errors. Creates a 0 size filename in directory sometimes

how to get the wifi access-password from the printer?

On the printer LCD, go down to the circle/gear icon, then go to WLAN

there I am

there I find my W-Lan. and the IP address of the printer.
And I can click: forget it

where is the password?

do you have screenshots/photos?

that can’t be that hard… or am I too stupid?

Sounds like you need to do the firmware update. Try powering off the printer using the switch at the back, then powering it back on after a moment. It will prompt to update.